Important Note for Linux users

 

PdfBooklet is developed originally in Windows and for Windows. Nevertheless it works perfectly on Linux, we have made the code compatible. It runs in Python 2.7 or 3.4.

The .deb package should work out of the box.

 

Pick the file you need here :

Download Linux

 

In case it does not, we are providing other solutions. 

1) Install from source

Decompress the file : Install by unzipping – linux.zip in a directory where you have full write rights. Run pdfbooklet.py with the following command :

 

python pdfbooklet.py

or

python3 pdfbooklet.py

 

If you have the dependencies satisfied, the program should run. If not, either install the missing packages, if you know how to do that, or use the second solution :

 

2) Install the pyinstaller bundle

To solve the dependencies problem, we have built a bundle with pyinstaller, which contains everything needed : Python3, Gtk3, Poppler.

Unzip the big file : pdfbooklet 3.x.x pyinstaller.zip, in a directory where you have write rights.

Run the file : pdfbooklet

3) Install from tarball

We offer also the tarballs in 32 and 64 bits if you know how to install them.

 

Technical information

 

The needed dependencies for python3 are :

  - sudo apt-get install python3-gi

  - sudo apt-get install python3-gi-cairo

  - sudo apt-get install gir1.2-gtk-3.0

  - sudo apt-get install gir1.2-poppler-0.18

 

For python 2.7 :

- sudo apt-get install  python-gobject-cairo